6

I have to ask an engine-related question: after I installed the Stockfish 2.0.1 engine on my Winboard 4.5 beta, I can't analyze with it. What I mean is, it's giving nothing in the engine output; it can only analyze with the default engines that come along with it (Houdini 1.5a, Delfi and Phalanx). What may be the reason?

  • 1
    Stockfish is up to version 2.2.2 now. Do you have a particular reason for using 2.0.1? (Not that I have any reason to believe the version you're using is causing your particular problem.) – ETD Jun 29 '12 at 19:13
  • Thats not the answer of the question i asked, any other answers welcome – user368 Jun 30 '12 at 10:07
  • 1
    Winboard doesn't seem particularly good for supporting UCI engines. There actually used to be an adapter to convert UCI to winboard called polyglot. – Eve Freeman Jul 1 '12 at 1:51
2

Stockfish is a UCI engine so it doesn't understand xboard as they are different protocols. As user @WesFreeman mentioned in the comments, polyglot is an adapter that can get UCI working under Xboard/Winboard. Perhaps visiting the Winboard Startup Dialog or reading the help file may assist you in resolving this issue.

Winboard can also execute polyglot internally if you use -fUCI in the command line, i.e.

xboard -fUCI -fcp stockfish -sUCI -scp stockfish

To download the required programs, you can type:

sudo aptitude install xboard polyglot stockfish

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.