0

It looks like xboard GUI and stockfish engine are not close friends.

I can pick stockfish as an engine in xboard, but stockfish will not respect the time limits (unlike if it is used by chessX). xboard will then simply timeout the stockfish engin, saying "White flags fell".

Is this a principal problem, or am I just missing the proper options to xboard and/or stockfish?

Background: I have recently resumed to playing chess against a computer opponent. With chessx and stockfish I lose every game very rapidly. With xboard there is a fairy-engin included that plays much weaker, but still I would lose. With limiting the strength of the engin (by restricting the engines time), I also play weaker, making me lose over again.

Now, I see the weakness is within myself, I want it rough: a strong engine, like stockfish, but it won't go with xboard.

5
  • xboard protocol is really old. all chess engines use UCI nowadays. have you tried a different GUI?
    – qwr
    Commented Apr 28 at 20:23
  • @qwr yes, previous to xboard I have tried chessx, but it comes without preinstalled engines and, on my system, there were some troubles when chessx tried to write on places where there was already some writing, messing up that part of the display. I also love that feature of xborad that informs me about the estimation of the game. Commented Apr 28 at 20:31
  • you can also play against stockfish on lichess and chess.com
    – qwr
    Commented Apr 28 at 23:29
  • @qwr I'm more than a little bit paranoid. I prefer playing on my own box. Commented May 2 at 19:55
  • have you tried other chess GUIs? Arena is useful and I use cutechess because it's free and open source and cross-platform.
    – qwr
    Commented May 2 at 21:04

3 Answers 3

0

Lucas Chess is a very fun interface that incorporates Stockfish among several dozen internal chess engines. Lucas Chess also contains many small engines for modest players. It is free software and exists in Linux and Windows versions. To download here: https://lucaschess.pythonanywhere.com/downloads

1
  • I've installed the software from your link, and there is a runnable RunEngines, that makes the engines runnable. Testing one, it starts, but, without board to call it, naturelly, it does nothing else. There is also a directory DigitalBoards, but it contains only libraries. With xboard, I don't see these many engines. What click am I missing? Commented May 4 at 21:39
0

I have no problem running stockfish or a dozen other UCI engines under xboard, even running tournaments between engines at 40 moves per minute. Check a couple of things. Have you installed polyglot? If not, do install it. I had some problems when polyglot was not installed. Also, check if you can run stockfish on the command line. Run stockfish (or whatever your executable is called) in a terminal, then run the command bench. That will confirm that SF is working.

9
  • I've installed polyglot about half an hour before and tried to run stockfish engine ... it is now about 20 minutes overdue and xboard is already advertising that "White flag's fell" but stockfish hasn't noticed yet, and will probably be consuming computer time forever if not stopped forcefully. What I am missing? Commented Apr 30 at 18:06
  • I can try to help debug this. Did you try running stockfish on command line? Could you post your configuration of stockfish in your .xboardrc file. Did you install stockfish from the stockfish site or from the Ubuntu repository? I have the following lines in my .xboardrc file (one for the version with handcrafted evaluation and one for version 16.1). On my machine I use the avx2 binary. "Stockfish 15 (hce,nn)" -fcp stockfish-15-hce-nn -fUCI -fNoOwnBookUCI "Stockfish 16.1" -fcp stockfish-16.1 -fUCI -fNoOwnBookUCI (I am not able to edit this properly.)
    – chesskobra
    Commented May 1 at 11:49
  • "Stockfish 15 (hce,nn)" and "Stockfish 16.1" are on separate lines in the section -firstChessProgramNames in the .xboardrc file. Also, stockfish-15-hce-nn and stockfish-16.1 are the names of my executables, which I have placed in /usr/local/games.
    – chesskobra
    Commented May 1 at 11:52
  • Yes I tried stockfish on the command line, but that was at a time I was not aware it needs to be called by a GUI. I dowloaded everything but stockfish via ubuntu. Stockfish I downloaded directly (I don't remember from where) and after some failed attempt, succeed in compiling it. The file .xboardrc is present, but won't fit into a comment. Commented May 2 at 20:05
  • I just need to know what the line for SF looks like in .xboardrc file. Mine is: "Stockfish 16.1" -fcp stockfish-16.1 -fUCI -fNoOwnBookUCI - here you should replace stockfish-16.1 with whatever your executable is called. Where have you placed your executable? I place it in /usr/local/games. If you have it in the directory where you compiled, then xboard will not see it; it needs to be installed in a path that xboard can see (generally /usr/local/games or /usr/local/bin etc for manually installed programs. Did you run the bench command after starting SF on command line?
    – chesskobra
    Commented May 2 at 20:27
0

I solved this issue by just reinstalling polyglot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.