I installed SCID on my Mac (Ventura 13.1) and I was able to load a database of games. I right clicked and selected “Load at startup” but after I close and reopen SCID I only see the Clipbase.

I tried both SCID 4.8 and the 5.0 beta. Same results :(

I also tried restarting my Mac but no luck. (The layout wasn’t saving for some reason, but this was solved with a Mac reboot)

  • I know that this question is aimed at software (hence one downvote so far), but it's still chess-software. If it's too far removed from the scope defined in chess.stackexchange.com/help/on-topic, then perhaps it could be migrated to something like SO, rather than closed? Jan 18 at 3:40
  • 1
    Thank you for the benefit of the doubt. The link your shared suggests chess software as a grey area. FWIW I also reported this issue in the SCID issue tracker and came here to ask precisely for the answer given below by Shivputra (that I will test as soon as I get back to "chess Mac").
    – nicktmro
    Jan 19 at 6:02
  • Personally, I think it's a good fit for this SE, but when it came up for being closed, I figured that I should at least suggest a potential migration instead, since the issue that it brings up is bound to come up for others (hence be a useful and important question that others might very well need an answer to). Jan 19 at 7:54

1 Answer 1


It sounds like there may be an issue with the way SCID is saving the database settings when you load it at startup.

Here are a few things you can try:

Make sure that the database you want to load at startup is the default database in SCID. To do this, go to File > Set Default Database and select the database you want to use.

Try manually opening the database you want to use after SCID starts up. To do this, go to File > Open and select the database you want to use.

Check the preferences settings. Some versions of SCID have an option in the preferences to load a specific database at startup. This option can be found in the File menu, in the preferences section.

Try saving the layout of the database with the layout you want. In some versions of SCID, the layout isn't saved after closing the program, so it's necessary to save it manually by going to View > Save Layout.

Try using a different version of SCID and see if that resolves the issue.

If none of these steps solves the problem, it may be a bug in the version of SCID you are using, and you may want to contact the developer for assistance.

  • Unfortunately I do not have an option under File to "Set Default Database". I will try the "different version of scid" suggestion. Will look at SCID vs PC and ChessX to see if I have better luck. Cheers
    – nicktmro
    Jan 19 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.