4

I am using Arena with Stockfish-222-64-ja-intel. It thinks about 50 moves deep and heats up my laptop processor. All I was interested in, was a depth of about 12-13 moves and for the best line to be shown on the top. I am not able to find the options to configure the gui is such a manner. Let me know if you have an answer.

Update: I know how to limit the level for computer strength. That's plain - it's Levels>>Adjust>>Fixed Search Depth>>8 half moves. The problem still persists though. When I click the Analyze button, the computer starts thinking really deep (and yes, the heating problem is a bit irritating and drains the battery).

1
  • 8 half moves means from 8 moves for each side. if you want 12-13 moves, reduces it to Levels>>Adjust>>Fixed Search Depth>>6 half moves. Aug 27 '13 at 4:52
1

What you want to do is limit the number of cores Stockfish has access to. I'm sure your computer/laptop has more than one core, but if improperly set, a UCI engine can eat up all of your processing power and leave your computer sluggish. There are two ways to fix this.

Arena should have a "Lower than normal process priority" in Engine Management Options. You should check this off.

Also, I know Chessbase lets you allocate a certain amount of cores (or threads) for the engine, and I'm sure Arena does as well. However, I'm not entirely sure how to do it with the specified software.

1
  • While addressing the overheating, this can just be annoying when you only want a 12-13 move depth. I too find this frustrating - if I just make a move, the resulting engine honors the 8 move deep setting. But if I click analyze, it will go for ever! So I'm not sure this really answers teh question.
    – corsiKa
    Jan 15 '16 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.