3

I'm trying to make syzygy browsing tool fathom.exe work. If you have experience with this, please let me know. I tried million of combinations of tokens to format the position command and the program always returns empty string.

When I run this command

FILE* pipe = _popen("c:\\fathom.exe --help", "r");

program returns this info string:

usage: c:\fathom.exe [--help] [--path=PATH] [--test] FEN

WHERE:
FEN
    The position (as a FEN string) to be probed.
--help
    Print this helpful message.
--path=PATH
    Set the tablebase PATH string.
--test
    Print the result only.  Useful for scripts.

DESCRIPTION:
This program is a stand-alone Syzygy tablebase probe tool.  The
program takes as input a FEN string representation of a chess
position and outputs a PGN representation of the probe result.

In addition to the standard fields, the output PGN represents the
following information:
- Result: "1-0" (white wins), "1/2-1/2" (draw), or "0-1" (black wins)
- The Win-Draw-Loss (WDL) value for the next move: "Win", "Draw",
  "Loss", "CursedWin" (win but 50-move draw) or "BlessedLoss" (loss
  but 50-move draw)
- The Distance-To-Zero (DTZ) value (in plys) for the next move
- WinningMoves: The list of all winning moves
- DrawingMoves: The list of all drawing moves
- LosingMoves: The list of all losing moves

The PGN contains a pseudo "principle variation" of Syzygy vs. Syzygy
for the input position.  Each PV move is rational with respect to
preserving the WDL value.  The PV does not represent the shortest
mate nor the most natural human moves.

Can you write me please an exact string command to analyse for example

4k3/4n3/8/8/4K3/8/1B2B3/8 w - - 0 1

My wdl folder is C:/Tablebases/Syzygy/wdl

My dtz folder is C:/Tablebases/Syzygy/dtz

  • 1
    Please note it's not possible to make it work unless you copy your files into the same directory. – SmallChess Dec 29 '16 at 12:14
  • I'm now looking at it and I must first make sure that operating system or antivirus doesn't block the program under some circumstances... – hoacin Dec 29 '16 at 12:21
  • Don't bother to check. Your output means your usage is wrong. I have seen it before. If your anti-virus blocks it, it wouldn't even run. – SmallChess Dec 29 '16 at 12:22
  • Right now even the exact line with --help that worked at time of writing the post doesn't work. SmartScreen woke up and blocked it suddenly. I think I should check what's going on. – hoacin Dec 29 '16 at 12:26
  • Please close all anti-virus and other related programs just for testing. Fathom is safe and open-source for you to run. – SmallChess Dec 29 '16 at 12:28
1

I have experience working with Fathom in one of my iOS apps. Look at my recent post:

http://talkchess.com/forum/viewtopic.php?t=62378

My command was: fathom --path=YOUR_PATH --test "FEN_STRING"

  • Substitute YOUR_PATH with your path. You must have both WDL and DTZ files in the same directory.
  • Substitute FEN_STRING with your FEN string. You will need the quotation mark.

My console session posted in the link:

enter image description here

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.