2

I'm installing stockfish to be used on SCID. I followed these two tutorials, using Stockfish from the Stockfish website rather than from git.

https://www.chess.com/article/view/scid--stockfish
http://support.stockfishchess.org/kb/advanced-topics/compiling-stockfish-on-linux

I downloaded the engine binaries for Stockfish7 for Linux from

https://stockfishchess.org/download/

I read that you need to compile it first so I compiled the Stockfish engine with sudo apt-get install git g++. Tested it with make profile-build ARCH=x86-32 then I went to add the engine in SCID, with these settings:

name: stockfish
command: stockfish
directory: /home/user/Desktop/stockfish-7-linux/Linux/src/.stockfish
UCI on

But then it tells me that it is unable to start the program: stockfish.

That error is the default response for any error. If I typed in folders that don't exist and a file that doesn't exist, it gives that error too. What am I doing wrong?

4

In the line:

name:stockfish command: stockfish directory: /home/user/Desktop/stockfish-7-linux/Linux/src/.stockfish UCI on

Are you sure your exe file is called ".stockfish" and not only just "stockfish". Seems odd that you have a hidden exe file (even that it is possible)

  • I have replaced directory: /home/user/Desktop/stockfish-7-linux/Linux/src/stockfish and also comfirmed that there is indeed an exe called stockfish in that folder, however the same error persists. – Qwertford Jun 12 '16 at 23:12
  • Are you able to start th eexe from the cmd line ? Can you post an exact dump of the error you get ? – U. Hjort Jun 13 '16 at 9:08
  • apologies, I hadn't realised that command had to be the location of stockfish. – Qwertford Jun 13 '16 at 16:54
  • Does that mean that it works now ? – U. Hjort Jun 14 '16 at 13:18
1
  1. Make sure you are pointing to the binary distribution of Stockfish and not the source. The binary distribution should be a variation of stockfish_10_x64.

  2. Make sure this binary has execute permissions:

    chmod u+x stockfish_10_x64
    
1

The solution is:

This command right here, as linked: /home/yourusername/.scid4.7/Linux/stockfish_10_x64

It worked for me.

I went into a search and found "Stockfish." Then I went onto "copy link location," and pasted it into command (I copied the Stockfish files in the SCID folder).

I hope that someone finds this helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.